Between 08:45 AM GMT+1 (UTC +01:00) and 02:30 PM GMT+1 (UTC +01:00), some customers in North America experienced issues with workflow actions. This was caused by a data integrity issue. As of 02:30 PM GMT+1 (UTC +01:00), our workflow actions are working properly and the incident has been fully resolved.
HubSpot conducts a thorough review after each incident to understand the cause and prevent it from happening again. Learn more about HubSpot's commitment to reliability at www.HubSpot.com/reliability.
The information on this page reflects our understanding of the incident and impact at the time of the update.
Posted Aug 21, 2026 - 08:27 EDT
Monitoring
We've addressed the issue that caused some workflow actions to be delayed in accounts hosted in North America since 08:45 AM GMT+1 (UTC +01:00). We're monitoring performance closely to ensure the tools recover properly.
The information on this page reflects our understanding of the incident and impact at the time of the update.
Posted Aug 21, 2026 - 08:09 EDT
Identified
We have Identified the root cause leading to some workflow actions being delayed in accounts hosted in North America since 08:45 AM GMT+1 (UTC +01:00).
We are scaling the system to mitigate impact and engineers are working diligently to resolve the issue and process all delayed actions.
We will be back with an update within 30 minutes.
Posted Aug 21, 2026 - 07:26 EDT
Update
Some Workflow Actions have been delayed in accounts hosted in North America since 08:45 AM GMT+1 (UTC +01:00). We are investigating the cause and will update this page when we have more information. We will be back with an update within 30 minutes.
The information on this page reflects our understanding of the incident and impact at the time of the update.
Posted Aug 21, 2026 - 06:48 EDT
Update
Some Workflow actions have been delayed in accounts hosted in North America since 08:45 AM GMT+1 (UTC +01:00). We are investigating the cause and will update this page when we have more information. We will be back with an update within 30 minutes.
The information on this page reflects our understanding of the incident and impact at the time of the update.
Posted Aug 21, 2026 - 06:12 EDT
Investigating
Some Workflow actions have been delayed in North America since 08:45 AM GMT+1 (UTC +01:00). We are investigating the cause and will update this page when we have more information. We will be back with an update within 15 minutes.
The information on this page reflects our understanding of the incident and impact at the time of the update.