Between 10:57 AM EST and 11:05 AM EST on April 11, 2025, we observed elevated error rates and slow responses impacting our Dashboard UI, Global Search and Reporting in North America. The incident has been fully resolved. No data was lost.
Posted Apr 11, 2025 - 11:32 EDT
Monitoring
Between 10:57 AM EST and 11:05 AM EST on April 11, 2025, we observed elevated error rates and slow responses impacting our Dashboard UI and Global Search and Reporting in North America. We have mitigated the issue and are now monitoring. We will be back with an update within 30 minutes.
Posted Apr 11, 2025 - 11:20 EDT
Investigating
Between 10:57 AM EST and 11:05 AM EST on April 11, 2025, we observed elevated error rates and slow responses impacting our Dashboard UI and Global Search and Reporting in North America. We're investigating what's causing this issue. We will be back with an update within 30 minutes.