Deals is unavailable for some customers

Incident Report for HubSpot

Resolved

Deals is now fully accessible. We've identified and addressed the root cause of the issue. The incident has been fully resolved and Deals should be working properly. No data was lost.
Posted Aug 01, 2025 - 13:08 EDT

Investigating

Deals isn't available right now. We're investigating what's causing this issue and will update this page when we have more information. Only customers hosted in North America are currently impacted. We will be back with an update within 15 minutes.
Posted Aug 01, 2025 - 12:55 EDT
This incident affected: CRM.