HubSpot may be unavailable for some users

Incident Report for HubSpot

Resolved

Between 12:19 PM (UTC -07:00) and 12:40 AM (UTC -07:00), many customers in North America experienced issues with marketing tools, operations tools, sales tools, service tools. This was caused by a server impairment. As of 12:40 AM (UTC -07:00), our marketing tools, operations tools, sales tools, service tools are working properly and the incident has been fully resolved.

HubSpot conducts a thorough review after each incident to understand the cause and prevent it from happening again. Learn more about HubSpot's commitment to reliability at www.HubSpot.com/reliability.

The information on this page reflects our understanding of the incident and impact at the time of the update.
Posted Apr 16, 2026 - 15:44 EDT

Identified

We estimate that we will restore service in the next half an hour.

We are mitigating impact from a server impairment which we believe is caused by resource exhaustion. We are scaling the system.

We will be back with an update within 15 minutes.

The information on this page reflects our understanding of the incident and impact at the time of the update.
Posted Apr 16, 2026 - 15:32 EDT

Investigating

We're investigating reports that HubSpot may be unavailable for some users. We'll update this page when we have more information.
Posted Apr 16, 2026 - 15:23 EDT